Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
44 user(s) are online (5 user(s) are browsing Forum)

Members: 0
Guests: 44

more...
Top Posters
Report message:*
 

the Imagine version 2.2 must exist!

Subject: the Imagine version 2.2 must exist!
by Marabufx on 2018/9/21 6:35:45

But there must still have been an Imagine Version 2.2 after the Imagine 2.19 version! Because Eagles film has always been set on Impulses Imagine3d since Amiga times. Here Eagles Film has released a demo, which was made according to their own information with the version 2.2!

The question is, why did CUP User scare us so impulses and this version despite our paid 3.0 CUP's this version never handed over?

Here's the proof of Eagles-Film itself ..
https://www.youtube.com/watch?v=5Dyl6UZ9iw4
Search
Powered by XOOPS © 2001-2009 The XOOPS Project